Database Upgrade
Incident Report for Qminder
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 08, 2018 - 03:56 EET
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Jan 08, 2018 - 03:10 EET